Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me

TOPIC: Integrator 3 Performance and stability

Integrator 3 Performance and stability 2 years 7 months ago #6913

  • Dmitri
  • Dmitri's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Karma: 0
Been trying to get Integrator work withing one week.
Product is really unstable, "Remember me" at login page doesn't work at all.
Pages mapping unstable, I have to spend hours to get work just few pages done. Guys, if you will let customer just to disable this bonus, your customer life will be much much better, at least this is my dram.
Biggest problem is performance, Integrator itself slows down site dramatically, but this might be even acceptable if I would be able to optimize home page.
And here is main problem, I can't use any optimization tool at all!!! Cache MUST be OFF, otherwise users access rights doesn't work! CDN MUST be OFF, otherwise integrator goes down. I can't use boosters plugins in Joomla that cause problems.
As result, Integrator can work if you slow you site down.

This might be acceptable for beta or free application. Unfortunately I spent too much resources for migration to Joomla before I bought Integrator, this is main reason why I didn't request money back.

Of course I still have hope that you guys will fix problems. You should find way to get straight connection between products, I believe that most of your clients have all products installed on the same server. You should fix issue related to general site optimization especially related to cache and CDN.
The administrator has disabled public write access.

Integrator 3 Performance and stability 2 years 7 months ago #6915

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Dmitri,

Thank you for your feedback on our product - I do agree with a number of points such as the product adding a bit of overhead to the server load times. This is unavoidable due to the nature of the product and integration. I can tell you that running I3 on a reseller hosting plan is not really feasible, and running it on a VPS plan can work if the server is not oversold dramatically. Last year the company we were hosted with started overselling our server and the performance hit was noticable. We have since moved off to our own dedicated server and have it tuned and optimized for our site, but with no CDN or caching.

Integrator 3 can work with certain CDN solutions, but it can't be guaranteed to work with each one. This is particularly true if there are some pages using ssl and some pages not using ssl. I have successfully used the CDN solution from NoNumber in the past with Integrator 3.

Caching can also be used, depending on the setup. I have also used Jot_cache in the past with I3.

These aren't endorsements, and it's been a while since I used them myself and the configuration is tricky to get down right, but it can be done.

Concerning the "Remember Me" not working, are you referring to the Remember Me box on the [IntegratorURL]/user/login page or on another connection? It may be a bug I'm unaware of but would be happy to address, just need to know where you are starting from.

Page mapping has actually been one of the best features of the product and most people don't encounter many issues there - always be sure any pages that you map are 'Public" and not requiring the user already being logged in as Registered or it won't work properly if the user hasn't logged in yet.

Version 3.1 is in the works and is a revamp of the API to speed up performance and make some important security enhancements. It is also going to simplify the installation and configuration process.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Integrator 3 Performance and stability 2 years 7 months ago #6916

  • Dmitri
  • Dmitri's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Karma: 0
Thanks Steven,
About Remember, there is screen short attached. Actually it doesn't work at your portal as well. I just didn't noticed that before, I have to login again all the time.

I am on own server, there is nothing about reseller hosting, my server doesn't overloaded and work quite fine. Joomla and WHMCS works absolutely fine and there is no any issue with performance. I have filling that performance problem come from routing.

At my site general pages goes via http and client area under https, I believe that is standard setup and ssl obviously mandatory.

About caching in Joomla, when it on all looks fine, but problem located in user access rights. Logged in user still see menu for unregistered user and can't see own menu.

CDN, I use CloudFlare, when it on, integration doesn't work.

Page mapping, if you can allow user to switch it of, that would be great. I got Idea of that feature, but some time, good to limit functionality to avoid unnecessary problems and improve speed.
Attachments:
The administrator has disabled public write access.

Integrator 3 Performance and stability 2 years 7 months ago #6919

  • 7hz25em7v8w7
  • 7hz25em7v8w7's Avatar
  • Offline
  • Fresh Boarder
  • KyneticWeb
  • Posts: 4
  • Karma: 0
Hi, I recently had been running into the same dilemma on my company site and have found a solution that is working properly with no issues. Here is a copy of a ticket I sent in with the solution to GoHigherIS. I will go ahead and add it here to help.

I had added custom page rulesets etc... but the problem lies within CloudFlare's Firewall settings. So here is what you can do to solve these issues. I will say I have been running extensive test on the settings and it's working splendidly now.. gzip and jot_cache are set (with custom .htaccess rules) and CloudFlare... no issues exists.

Here it is.

Within your CloudFlare panel you will need to navigate to your "Security" Tab -->
Then you need to enter your "Firewall" WAF (Web Application Firewall) --->

Head down to CloudFlare --> CloudFlare Specials

Within the CloudFlare Specials Firewall settings you need to disable "Empty User-Agent"

This setting enabled is counting the I3 login process as a potential security threat.. thus blocking the component.


Once disabled, all works as it should. We have RailGun and CloudFlare and both are humming along.

There really is no need for the setting to be enabled (Empty User-Agent) in CloudFlare as proper Joomla! security is already taking care of those bits.
The administrator has disabled public write access.
Time to create page: 0.041 seconds
Powered by Kunena Forum