Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: API Successful in Joomla but not in WHMCS

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6776

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
I am having trouble connecting Joomla! 3.2 to WHMCS V.5.2.14 using J!WHMCS.
First, it is my understanding that Auto Auth and API Token are the same item.

After following directions for J!WHMC V2.5 installation in Joomla and WHMCS, I have the following results being shown in each.

In Joomla:
Successfully connected! Your settings are valid and have been saved.

In the API options, I have entered the same value for the token that I created and copied into the WHMCS configuration.php:

$autoauthkey = "p***********************2";

In WHMCS:
In the API options, I have entered the same value for the token that I created and copied into the WHMCS configuration.php:
-> J!WHMCS Integrator Settings panel:

Enabled and inserted the same Auto Auth /API Token as above
p***********************2


On the dashboard is the message:

API Connection Status
An error was encountered
attempting to connect to Joomla!
The error returned was:
Signatures do not match.
Verify your tokens are correct and try again.

And in System Check:
Token Valid: NO

For Reference:
API Admin is setup and has access rights for API Access only

I have been working on this problem for a week and have yet to come up with an answer.
Some help would be greatly appreciated.
Thanks,
Jim
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6778

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Have you tried to simplify the key being used? For example, using only alpha-numerics? It should work with symbols and characters also, but just in case something is changing those characters around be sure to try with just alpha-numerics.

That being said, I have encountered one install where it appeared that there was one setting in the database but another setting was being relied upon. Are you using any caching on the server to enhance performance at all? If so, try disabling any server level / database level caching and see if it allows you to connect. I may need to take a look at it directly to assist.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6780

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
I simplified the key as you suggested and entered it into J!WHMCS Integrator
WHMCS automatically updated its configuration.php file automatically for the new key.
Entered it in J!WHMCS and got successfully connected!
Went back to WHMCS to see results and got the following status:

API Connection Status
An error was encountered attempting to connect to Joomla! The error returned was:
Signatures do not match. Verify your tokens are correct and try again.


As far as cache is concerned, Joomla cache was set to OFF
The server is LINUX and handles it's own caching.

I would appreciate it if you could find the time to determine the cause as I have run into a wall....ouch...ouch...ouch,,,repeatedly.

Let me know how you want me to provide you with credentials.

Thanks,
Jim
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6781

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Be sure you don't have any SEO / SEF applications running in Joomla against the JWHMCS application. If you have AceSEF, MijoSEF, sh404sef etc configure them to ignore the JWHMCS application.

If you can enable the debugging in:
Joomla > Extensions > JWHMCS > Options
and
WHMCS > Addons > JWHMCS > Settings

I'll take a look at it directly for you and see what I can find.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6783

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
I do not have SEO or SEF turned on.
Debugging has been turned on. Thanks for your offer to look at this.
I was able to log in from Joomla and see WHMCS data in Joomla without Joomla templating....worry about that later, but am not certain why I was able to log in since WHMCS API is throwing an error apparently. Wasn't able to log in with a user that had been created in WHMCS.

Perhaps I should put this in another topic, but I have a question concerning the installation of J!WHMCS V1.5.9. Does it include the latest version of the J!WHMCS Login Module and if so is it V2.5.9 or a later one? The reason I ask is that if the module is already installed then I overwrote it when I installed V2.5.9 unknowingly and generated the following error.
Fatal error: Class 'JwhmcsParams' not found in /home/xxxxx/public_html/modules/mod_jwhmcslogin/mod_jwhmcslogin.php on line 35

Thanks,
Jim
Last Edit: 2 years 11 months ago by jparker3119. Reason: clarification
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6784

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

The login module is actually no longer needed as the method of displaying the user has changed. I'd recommend using just the regular user login module (or any other login module should also work now).

The debugging is enabled on the WHMCS side, but the Joomla side doesn't appear to be on. If you visit this URL:
[WHMCS_URL]/index.php?m=jwhmcs&task=checkrender

You'll see that WHMCS is getting back a 200 from Joomla, so everything should be working - copying the URL in the textarea on that page into your browser however results in an invalid signature warning - if you enable debug in Joomla this should not happen and should render the page as it appears (Joomla > Components > JWHMCS > Options > Debug: Yes)
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6789

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
I hope that you are enjoying the holiday season, Steven.
I have set the de-bug in Joomla's J!WHMCS "Debug" to ON.
**Debugging is enabled in J!WHMCS Integrator! Be sure to disable!**
Although I agree that everything is working normally, it is disconcerting to see the warning in the J!WHMCS Integrator Dashboard in WHMCS stating the following:
API Connection Status
An error was encountered attempting to connect to Joomla! The error returned was:
**Signatures do not match. Verify your tokens are correct and try again.**
And in J!WHMCS Integrator System Check
Token Valid: NO: The API attempted to verify the token and authorize access to Joomla but received this message back from Joomla: **Signatures do not match. Verify your tokens are correct and try again.**
I can ignore these messages and from what I see in responses in the forum, it is a problem that is unique to me apparently.
Last Edit: 2 years 11 months ago by jparker3119. Reason: clarification
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6793

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

I'm looking at your site and I see a ton of CURLOPT warnings - I'll have to address those in a new release of Dunamis. Can you enable the debug on the joomla side: Joomla Admin > Components > JWHMCS > Options > Debug

The curl handler is receiving a 200 response, but I just can't see what it's seeing yet.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6798

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
Thanks for taking a look at this, Steven.
I have Joomla->J!WHMCS->General->Debug->set to Yes

If you need admin access to Joomla! and/or the server, please let me know. I will provide you with user names and passwords.
Thanks
Jim
The administrator has disabled public write access.

API Successful in Joomla but not in WHMCS 2 years 11 months ago #6799

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

Thanks for the ticket with the details to further diagnose what was going on. Here's the change I made to get things working:

Your .htaccess file is forcibly redirecting from www to non-www (or at least a component or setting in Joomla is doing this). Because of this, since you had www.yourdomain.com as the Joomla URL in your WHMCS settings, each time it tried to connect it would get forced to redirect to yourdomain.com and in doing so would lose the signature and details to allow it in.

Once I changed that to non-www, the site came right up.

Please let me know if I can assist further in any way.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.072 seconds
Powered by Kunena Forum