Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me

TOPIC: No Wrap and No Settings in whmcs addon

No Wrap and No Settings in whmcs addon 2 years 11 months ago #6785

  • Artie
  • Artie's Avatar
  • Offline
  • Junior Boarder
  • Posts: 30
  • Karma: 0
1. I am no longer able to get access to the settings tab in whmcs (once I set the correct joomla dir), even changing these settings in php my admin doesnt return access.

2. jwhmcs in whmcs is giving me license attitude (what else is new). I re-issued it multiple times, still shows error in dashboard.

3. seems like joomla and whmcs are connected but no wraping is going on, I don't even know how this new version gets wraping since it doesn't use custom theme.

Please help
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 11 months ago #6786

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Thanks for posting in the forum:
  1. I'd need to know what you mean - do you mean the drop down menu on the top of WHMCS containing the settings or do you mean the J!WHMCS Integrator settings in the product? Also, are you using a custom WHMCS admin template?
  2. You will need to reissue the license, but if you have done this and it isn't saving then it sounds like you need to disable JWHMCS from the backend of WHMCS (WHMCS > Setup > Addon Modules) then enable the Dunamis framework FIRST... then enable JWHMCS. The order matters.
  3. If you enable debug in the settings of JWHMCS in WHMCS > Addons > JWHMCS > Settings > Debug you can visit the front end of the web site and add the following to the URL:
    /index.php?m=jwhmcs
    This will gain you access to the debug screen for JWHMCS on the front end, which will help troubleshoot connectivity issues.

Let me know if I can help further.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 11 months ago #6787

  • Artie
  • Artie's Avatar
  • Offline
  • Junior Boarder
  • Posts: 30
  • Karma: 0
1. I am not using a custom admin template. The settings that go to a 500 page are the ones in the whmcs jwhmcs addon package, otherwise joomla is fine. This remains the only issue.
2. License issue fixed (wooooot)
3. It is now starting to wrap properly although needs work to make it look right.

"If you enable debug in the settings of JWHMCS in WHMCS > Addons > JWHMCS > Settings > Debug"
this is the part where I don't have access to, even after following the instructions in part 2.
ERROR 500 - INTERNAL SERVER ERROR
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 11 months ago #6788

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hmm... so when you access the settings in WHMCS > JWHMCS > Settings it returns a 500? What version of J!WHMCS Integrator do you have installed? If the front end is wrapping that would indicate to me that at least the URLs are correct to retrieve the Joomla site. If you upgraded from a prior version, be sure to remove form the WHMCS side the following:

[WHMCS]/jconfig.php
[WHMCS]/jwhmcs.php
[WHMCS]/includes/hooks/jwhmcs*.php
[WHMCS]/includes/api/jwhmcs*.php

If it's still giving you a 500, I think I'll need to inspect it directly - if you could open a ticket I can troubleshoot this and try to resolve it for you.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 10 months ago #6842

  • Artie
  • Artie's Avatar
  • Offline
  • Junior Boarder
  • Posts: 30
  • Karma: 0
WHMCS > JWHMCS > Settings it returns a 500 correct

I deleted the [WHMCS]/includes/api/jwhmcs*.php with no improvement
My clients have no access to header.tpl and footer.tpl which make the integration complete. Please help as I am getting lots of emails about this.
Submitting ticket on this as recommended.
Last Edit: 2 years 10 months ago by Artie.
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 10 months ago #6843

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
What version of PHP are you running on your server? If it isn't 5.3 or higher, that could be causing this issue.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 7 months ago #6918

  • Brseed
  • Brseed's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hello,

Im having exactly the same problem, when i click in the setting tab, i get error 500

What was the solution?

My PHP Version 5.2.17

Thanks
The administrator has disabled public write access.

No Wrap and No Settings in whmcs addon 2 years 7 months ago #6922

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Just seeing this post, I apologize for the delay.

For those customers that have encountered this issue, increasing the available PHP memory in your php.ini file resolved it for them. I've had a couple that were on a smaller VPS package with more limited resources and for those customers I had to hard code a correction (which I need to implement product wide yet).

If increasing the memory doesn't resolve it, please open a ticket and I'll be happy to take a look and try to get this solved for you.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.
Time to create page: 0.040 seconds
Powered by Kunena Forum