Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me

TOPIC: Unlogged in users not provided template

Unlogged in users not provided template 2 years 10 months ago #6819

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
Happy Monday, Steven.

Users who wish to use our services need to first subscribe for it via the whmcs cart.php

This is possible now but when the link is clicked on, the cart is displayed without any of the Joomla layout.
However, if a person who is logged in, clicks on the page, the page is displayed properly.

You can view this in action using the following steps: az-soho.net -> Shop -> AZ-Soho Membership
The page is displayed but without the css styling and the normal az-soho background.

Please advise.

Thanks
Jim
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6820

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

Is the link being requested by J!WHMCS to wrap around WHMCS a 'registered' or 'special' link? If so, it needs to be public, as the user isn't yet logged in and not able to view it yet.

You can check by looking in WHMCS > Addons > JWHMCS > Settings > Visual and see which menu item is being retrieved from Joomla, then check your Joomla menu for that item and verify it is Public.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6822

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
Thanks for your quick reply, Steven.

I see that I had made a conceptual mistake in that I was thinking that J!WHMCS would wrap Joomla around WHMCS from any link, which of course it does not since only one menu can be designated on WHMCS visual settings.

I then set [My Portal], which is the entry way into WHMCS to public. I also saw that it was properly designated in the WHMCS J!WHMCS visual setting as well.

The links were visible to an unlogged in user. Unfortunately, when clicked on the surrounding Joomla template was not integrated.
I tried with a logged in user, and the display was correct.

You should be able to view the page from the [My Portal] link. The credentials that I setup for you as a Joomla user before are still in effect so you may be able to see that the view is correct for a logged in person. If you no longer have the credentials, I will send them to you again.

Note: Is it possible to make only the WHMCS cart page visible to unlogged in users?

Thanks,
Jim

FYI: I doubt if there is any relationship, but I am using swMenuPro for the menus.
Last Edit: 2 years 10 months ago by jparker3119. Reason: clarification
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6825

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

When I go to the members area of your site, I'm seeing that it isn't wrapping, are you by chance using just //domain.name.com/ as the Joomla URL? Be sure it is a fully qualified domain including the scheme.

If you could enable the debug feature in WHMCS > Addons > JWHMCS > Settings > Debug I may be able to give you a better idea of what's going on.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6826

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
Was out of the office for the most part yesterday and so excuse my slow reply.

I didn't become aware of the non-wrapping problem until you mentioned it because it had been wrapping properly for me up to that point!
Since I got your comment about it, it hasn't wrapped at all!! :D

Obviously, there is a problem!

First, I am sorry but I do not understand your usage of the term "scheme." I see that it is used in the explanation provided on the API Connection Check page
(Side Note: There is a statement there that says: "For reference, your joomla site's URL has been entered below." Perhaps the term below should be changed to "above" ?, at least that is the way it is being displayed in Joomla 3.2.1
Also, I think it would be beneficial if the following explanation was added: "The WHMCS Url displayed here reflects what is set in Options. You cannot change the value here." )

I believe that there are only two areas that the URLs need to be set:
1. J!WHMCS -> Options -> API Settings -> WHMCS URL
2. J!WHMCS Integrator -> Settings -> General Settings -> Joomla URL

I tried the following 2 settings none of which wrapped:
1. J!WHMCS -> Options -> API Settings -> WHMCS URL (
https://www.az-soho.net/members
)
2. J!WHMCS Integrator -> Settings -> General Settings -> Joomla URL (
http://www.az-soho.net
)

I then tried the following settings using http rather than https:
1. J!WHMCS -> Options -> API Settings -> WHMCS URL (
http://www.az-soho.net/members
)
2. J!WHMCS Integrator -> Settings -> General Settings -> Joomla URL (
http://www.az-soho.net
)

I then tried the API Connection Check settings using http rather than https:
1. J!WHMCS -> Options -> API Settings -> WHMCS URL (
http://az-soho.net/members
)
2. J!WHMCS Integrator -> Settings -> General Settings -> Joomla URL (
http://www.az-soho.net
)

I have set debug in Joomla -> J!WHMCS Integrator Configuration -> General -> Debug -> Yes
I have set debug in WHMCS -> J!WHMCS Integrator Settings -> General Settings -> Debug -> Enabled

Please let me know if there is any more information that you need, Steven.
Thanks!
Jim
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6827

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hi Jim,

When I refer to the scheme, I mean the 'http' portion of the URL... in the URL:
http://www.az-soho.net/members

Scheme = http://
Subdomain = www
Domain = az-soho.net
Path = members

(technically I believe the scheme is just the http portion of the http:// but you need the :// so I include it when I refer to it)

If you look at the source for your WHMCS, it looks like the URLs for links and javascripts are being set as:
//www.az-soho.net/template/....

so they have the forward slashes but not a complete scheme. This may not be the cause of the problem however...

I noticed that you appear to be forcing everything to non-www is that right? If so you will want your URL settings to reflect that they are non-www. If the WHMCS > Addons > JWHMCS > Settings > Joomla URL says www.az-soho.net and you are redirecting to no-www, then the redirection loses the query variables that needt o be passed along to retrieve the site. I believe your settings should be:

J!WHMCS -> Options -> API Settings -> WHMCS URL
http://az-soho.net/members

J!WHMCS Integrator -> Settings -> General Settings -> Joomla URL
http://az-soho.net
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Unlogged in users not provided template 2 years 10 months ago #6828

  • jparker3119
  • jparker3119's Avatar
  • Offline
  • Junior Boarder
  • Posts: 27
  • Thank you received: 2
  • Karma: 0
Those settings worked, Steven. Thanks!
I have an additional question unrelated to this topic and will submit that one next.
Thanks, again.
Jim
The administrator has disabled public write access.
The following user(s) said Thank You: Steven
Time to create page: 0.041 seconds
Powered by Kunena Forum