Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me

TOPIC: Health Check failed in WHMCS

Health Check failed in WHMCS 2 years 3 months ago #6998

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
I am doing a complete rebuild and not sure if adding the users back from the old install messed this up or what but when I access JWHMCS Integrator in WHMCS I get this message:

Connection Made . Please check your settings and try again

Below this I am seeing an error for all users like this:

J!WHMCS Integrator returned an unknown error during Joomla user creation for a client (Client add) - User 23

What did I do wrong and what can I do to correct this?
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 3 months ago #7000

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
I figured that the problem could be that I needed to perform this as an upgrade rather than a new install even though I am building a new site. So I followed the instructions as if it was an upgrade and it did give me access to the WHMCS addon. However even though I purchased an update subscription it is failing to recognize the key and says it is invalid. Do I need a new key or is there something I have to do in order to activate the license?
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 3 months ago #7002

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
You shouldn't need a new key - I've reissued the license for you and it should bind correctly up - if not, please open a ticket and I'll jump in and take a look at it.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 1 month ago #7042

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
So I finally got time to get back on this and have made the connection. Now when I test the API connection check in Joomla I get this error.

The requested URL returned error: 403 Forbidden [http://****.com/WHMCS/includes/api.php]
COM_JWHMCS_APICNXN_HELP_

I checked the api.php and the permissions are correct. Looking at another post similar to this I saw where you mentioned adding the $api_access_key variable in your WHMCS configuration.php file. I tried a few different ways to do that but not sure I am doing ir right and it did not work.

Also in the same post you mentioned an issue with the htaccess file so I disabled that and no go, still did not work. You also mentioned adding a RewriteCond to exclude requests to the subfolder but again not sure how to write that out, tried a few different ways and still no go.

I am at a loss because everything appears to be connecting fine and nothing is showing in the error log or otherwise in WHMCS to indicate I missed a step. Any thoughts on why this is happening and could it be an issue with Adin Tools Pro? I tried adding some exceptions there and nothing worked.
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 1 month ago #7043

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Hmm... Aside from updating the password for the api user to ensure it is correct, you should verify the IP address is whitelisted (not just in the API Access box but also in the Whitelisted login box in the WHMCS > Security > General Settings > Security tab).

Another thought: if you are forcing SSL through an .htaccess rewrite, be sure to use the https scheme in the WHMCS url.

If you haven't already, you may want to open a ticket and let me take a look for you.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 1 month ago #7044

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
I will double check your suggestions but I have done all that and did more checking after opening this thread. Always miss something thought...
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 1 month ago #7045

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Still cant get it and when I tried to open a support ticket every time I clicked open a new ticket the site logs me out and asks me to login. I tried to go a round about way, logged in and clicked view all tickets and instead of showing me support tickets it tells me I do not have permission to carry out this action.

UPDATE: So this is a Chrome issue, I was able to open a ticket in FF.
Last Edit: 2 years 1 month ago by cog.
The administrator has disabled public write access.

Health Check failed in WHMCS 2 years 1 month ago #7046

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Concerning being able to open a ticket - you may need to log out and log back in with Chrome. I usually use Firefox, but when using Chrome I see it's caching a little too much even though I'm instructing the browser not to. See if that helps when using Chrome.

Do let me know what you discover about the server caching issue... I do want to know if it can help others.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.
Time to create page: 0.130 seconds
Powered by Kunena Forum