Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: `COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR:

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 2 years 2 weeks ago #7025

  • Dtorr1981
  • Dtorr1981's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
I am seeing this error whenever i log into Joomla. Please see image attached. Any ideas what is causing it?

Regards
Donna

Attachment ScreenHunter_797.gif not found

The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 2 years 2 weeks ago #7027

  • 7hz25em7v8w7
  • 7hz25em7v8w7's Avatar
  • Offline
  • Fresh Boarder
  • KyneticWeb
  • Posts: 4
  • Karma: 0
Hey Donna,

I had this same problem with one of my company servers.. it had everything to do with the component not handling IPv6 very well. I disabled IPv6 on the server and the plugin started handling hooks properly.

I'm sure Steven can have a better reply to this. Of course, with most server environments it's typical have a million flavors to one spoon.. this is just my approach that worked.. unfortunately it involves disabling IPv6
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 2 years 2 weeks ago #7028

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
That is strange, I hadn't seen any instances of IPv6 causing issues, I'd have to take a look.

One possible work around for a 403 issue would be to add the $api_access_key variable in your WHMCS configuration.php file, then specify the variable in the API Connection wizard within J!WHMCS on the Joomla side. This would essentially bypass IP restrictions set by WHMCS, in favor of using the access key.

I don't know if this is the same request that I had a ticket in for, but I had a customer with the same issue. Their WHMCS was setup as a subfolder within their site (so Joomla was in the root, then WHMCS in a subfolder). They had enabled the Joomla .htaccess file, and at the end of the file there was a call to force all requests that have not yet been routed by the .htaccess file to receive a 403 response. When disabling the .htaccess file, the API connected right up. To fix in this particular case, I added a RewriteCond to exclude requests to the subfolder and it worked from there on.

Not sure if that's of any help :)
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 1 year 11 months ago #7039

  • auzziebiz
  • auzziebiz's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 2
  • Karma: 0
I am having the same problem.
The J!WHMCS Integrator API interface returned the following error: `COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 403 FORBIDDEN `

I disabled the .htaccess however I still get the same error when I log in to Joomla administrator.
(see attachment 1)

I also have an error when using the API Connection Check.
The requested URL returned error: 403 Forbidden
COM_JWHMCS_APICNXN_HELP_

(see attachment 2)
Attachments:
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 1 year 11 months ago #7040

  • auzziebiz
  • auzziebiz's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 2
  • Karma: 0
I am unable to create a Support Ticket for this?
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 1 year 11 months ago #7041

  • cog
  • cog's Avatar
  • Offline
  • Junior Boarder
  • Posts: 31
  • Thank you received: 1
  • Karma: 0
Did you ever find a solution for this auzziebiz?
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 1 year 8 months ago #7059

  • Wub16lf1nc5i
  • Wub16lf1nc5i's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
Here is the easy and fast fix of the problem:

Login in whmcs admin panel - SETUP - GENERAL SETTINGS.
From the options choose Security and search for API IP Access Restriction. Just add the IP address of your joomla website. :)
The administrator has disabled public write access.
The following user(s) said Thank You: Steven

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 1 year 8 months ago #7062

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
Last Edit: 8 months 2 weeks ago by Steven. Reason: Correct URL
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 8 months 2 weeks ago #7186

  • 9653s9y0m4ns
  • 9653s9y0m4ns's Avatar
  • Offline
  • Fresh Boarder
  • I'm WebGuy
  • Posts: 3
  • Karma: 0
This URL is 404 - Page Not Found.
Mark W. Mumma, BCIP
WebGuy.com
I drive way too fast to worry about cholesterol.
The administrator has disabled public write access.

`COM_JWHMCS_API_THE REQUESTED URL RETURNED ERROR: 8 months 2 weeks ago #7187

I did just that and I still get this

The requested URL returned error: 403 Forbidden [hosting.goddessdivinedesigns.com/includes/api.php]
COM_JWHMCS_APICNXN_HELP_
The administrator has disabled public write access.
The following user(s) said Thank You: 9653s9y0m4ns
  • Page:
  • 1
  • 2
Time to create page: 0.084 seconds
Powered by Kunena Forum