Support Services

Fast and professional to support your business
Welcome, Guest
Username: Password: Remember me

TOPIC: WHMCS as a subdomain - connection fail

WHMCS as a subdomain - connection fail 1 year 11 months ago #7047

  • 7hz25em7v8w7
  • 7hz25em7v8w7's Avatar
  • Offline
  • Fresh Boarder
  • KyneticWeb
  • Posts: 4
  • Karma: 0
Hey guys,

We recently moved the WHMCS side of our site over to a subdomain, i.e; whmcs.mydomain.com instead of www.mydomain.com/whmcs

The license checks out and the API connects properly with no issues. There is however a problem with the site sending the login info over to Joomla!

Upon login via a WHMCS login form the following error is passed along the URL path.
https://www.mydomain.com/?timestamp=141XXX1629&signature=mo9fGcqxkllomcqopmXXXXHCyTSD6YesKpl5nYC5w%2BY%3D&checksign=SYrGTXXXX4GSHzxmJwfci4DuONmkUbBL3XXXXJ2iEQ4%3D&username=FirstName.LastName&task=autoauth&returnurl=aHR0cHM6LXXXXS5reW5ldGljd2ViLmNvbS9jbGllbnRhcmVhLnBocA%3D%3D

For the sake of whatever type of protection we have concealed various strings of characters in that link as well as renamed the persons name to 'FirstName.LastName'

Error console reveals absolutely nothing.

Upon navigating back to the joomla side of the site as the page is blank and the only thing is that text in the address bar.. we can see that the user has not been logged in. Going now to whmcs.mydomain.com/ shows us there is a successful login to WHMCS.

Any word on this would be tremendous. Hopefully J!WHCS works with wildcard subdomains as we're too vested in the new subdomain dashboard naming.
Last Edit: 1 year 11 months ago by 7hz25em7v8w7.
The administrator has disabled public write access.

WHMCS as a subdomain - connection fail 1 year 11 months ago #7048

  • Steven
  • Steven's Avatar
  • Offline
  • Administrator
  • Posts: 883
  • Thank you received: 60
  • Karma: 13
Thanks for the question - it sounds like it may be K2 causing issues... if you have K2 installed in your Joomla environment, go to Joomla > Extensions > Plugin Manager then sort the list by the System type plugins and order it so you can rearrange the order of the plugins. Be sure the System - K2 plugin is the VERY FIRST plugin fired, THEN the System - JWHMCS plugin. If it is the other way around, there are issues with K2 and this is just one of the possible issues that can occur.
Stars on the Joomla! Extension Directory are always appreciated
If you found this response useful, don't forget to hit Thank You!
The administrator has disabled public write access.
The following user(s) said Thank You: 7hz25em7v8w7

WHMCS as a subdomain - connection fail 1 year 11 months ago #7049

  • 7hz25em7v8w7
  • 7hz25em7v8w7's Avatar
  • Offline
  • Fresh Boarder
  • KyneticWeb
  • Posts: 4
  • Karma: 0
Wow, good call Steven!

You're absolutely right.. (as you usually are).. somehow K2 was ordered after JWHMCS. We never reordered the plugins so I'll have to figure out what happened there.

Thanks for your help.. on the Holidays as well!
The administrator has disabled public write access.
Time to create page: 0.070 seconds
Powered by Kunena Forum